[Webkit-unassigned] [Bug 71572] String new RegExp('\n').toString() returns is invalid RegularExpressionLiteral

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Nov 15 14:21:29 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=71572





--- Comment #7 from Yusuke Suzuki <utatane.tea at gmail.com>  2011-11-15 14:21:29 PST ---
(In reply to comment #6)
Thank you for your review.

> backslash is one word, not two, so this should be named previousCharacterWasBackslash
Yes, I'll rename it.

> > Source/JavaScriptCore/runtime/RegExpObject.cpp:145
> > +        if (ch == '\n' || ch == '\r' || (ch & ~1) == 0x2028) {
> This should use the inline isLineTerminator function instead of repeating its code.
Right, I'll change it to using Lexer<UChar>::isLineTerminator.

> This is indented wrong. Should be indented four spaces.
Oops. This is mistake.

I'll upload revised patch soon.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list