[Webkit-unassigned] [Bug 71854] Access key should work on all elements

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Nov 14 10:27:17 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=71854





--- Comment #29 from Erik Arvidsson <arv at chromium.org>  2011-11-14 10:27:16 PST ---
(From update of attachment 114851)
View in context: https://bugs.webkit.org/attachment.cgi?id=114851&action=review

Some hints on making the test cleaner.

> LayoutTests/fast/forms/access-key-for-all-elements.html:6
> +<p>This test checks to see if accesskey attributes works all elements.</p>

Use the description function instead.

> LayoutTests/fast/forms/access-key-for-all-elements.html:7
> +<div id="test"></div>

This element is never used

> LayoutTests/fast/forms/access-key-for-all-elements.html:8
> +<div id="console"></div>

Remove console element. It is not needed

> LayoutTests/fast/forms/access-key-for-all-elements.html:12
> +if (window.layoutTestController)
> +    layoutTestController.dumpAsText();

Remove, these are note needed

> LayoutTests/fast/forms/access-key-for-all-elements.html:14
> +var test = new Array("a","abbr","acronym","address","applet","area","article","aside","audio","b","base","basefont","bdo","bgsound","big","blockquote",

var test = ["a", ...];

> LayoutTests/fast/forms/access-key-for-all-elements.html:25
> +    var test_me = document.getElementsByTagName(test[i])[0];

WebKit style is to use camelCase.

A simpler solution might be to do:

var testElement = document.querySelector(tagNames[i]);

btw, I would probably rename test to tagNames or something more descriptive.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list