[Webkit-unassigned] [Bug 71595] [chromium] Add draw-time scale delta to compositor thread

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Nov 6 14:33:53 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=71595





--- Comment #8 from Alexandre Elias <aelias at chromium.org>  2011-11-06 14:33:53 PST ---
(From update of attachment 113742)
View in context: https://bugs.webkit.org/attachment.cgi?id=113742&action=review

>> Source/WebKit/chromium/public/WebLayerTreeViewClient.h:44
>> +    virtual void applyScrollAndScale(const WebSize&, float) = 0;
> 
> nit: please give the float parameter a name.  i think "scaleFactor" would work.
> the WebSize parameter could probably also benefit from a name:  "scrollDelta"

Done.

>> Source/WebKit/chromium/public/WebView.h:212
>> +    virtual void setScaleLimits(float minScale, float maxScale) = 0;
> 
> since this impacts "PageScaleFactor", it seems like the function name should include
> that term.  how about calling this function setPageScaleFactorLimits?

Sounds good, renamed everywhere.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list