[Webkit-unassigned] [Bug 70765] Default <select multiple> expands up to 10 items instead of showing 4

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Nov 1 02:50:58 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=70765





--- Comment #7 from Antaryami Pandia <xqb748 at motorola.com>  2011-11-01 02:50:58 PST ---
(In reply to comment #6)
> For clarity I might rephrase this as "The minSize constant was originally defined to render scrollbars correctly."
Done. 
> > Source/WebCore/rendering/RenderListBox.cpp:74
> > +// This might vary for different platform.
> 
> "platforms"
Done.
> > Source/WebCore/rendering/RenderListBox.cpp:80
> > +// IDL attribute is either 1 or 4 depending on the presence of the multiple attribute.
> 
> This comment is incorrect. The size IDL attribute is not a reflection of the actual size used. The link is also unnecessary. I would suggest just keeping the first line.
Done.
> > Source/WebCore/rendering/RenderListBox.cpp:226
> > +    return min(max(minSize, numItems()), defaultSize);
> 
> This evaluation is unnecessary. Because defaultSize and minSize are the same now, this will always evaluate to defaultSize. It's better to just return defaultSize.
Done.
> > LayoutTests/fast/forms/select-multiple-attr-with-no-size.html:23
> > +</html>
> 
> I'd like to see another test case (if it doesn't exist already) where the # of options is either 0, or fewer than the default 4 options.
Ok.
> > LayoutTests/fast/forms/select-multiple-attr-with-size-attr.html:23
> > +</html>
> 
> I'd like to see another test case (if it doesn't exist already) where the size specified is less than the minimum size.
Ok.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list