[Webkit-unassigned] [Bug 60936] Add currentTickCount() to get monotonically increasing time

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue May 24 16:47:10 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=60936





--- Comment #13 from James Robinson <jamesr at chromium.org>  2011-05-24 16:47:09 PST ---
(From update of attachment 94709)
View in context: https://bugs.webkit.org/attachment.cgi?id=94709&action=review

This seems like a good start to me - there's a good implementation here for PLATFORM(MAC) and a reasonable fallback for other platforms, so we can start depending on it now and then improve the implementations on each port as we go.  Does that sound good to everyone?

> Source/JavaScriptCore/wtf/CurrentTime.cpp:310
> +    return mach_absolute_time() / 1000 * timebaseInfo.numer / timebaseInfo.denom;

nit: the order of operations/evaluation here is hard to follow, could you reorder or add some parens?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list