[Webkit-unassigned] [Bug 60439] [Texmap][Qt] Upstream texture-mapper changes from Qt's WebKit2 branch
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Mon May 9 01:43:40 PDT 2011
https://bugs.webkit.org/show_bug.cgi?id=60439
--- Comment #46 from Kenneth Rohde Christiansen <kenneth at webkit.org> 2011-05-09 01:43:40 PST ---
(From update of attachment 92740)
View in context: https://bugs.webkit.org/attachment.cgi?id=92740&action=review
> Source/WebCore/platform/graphics/texmap/GraphicsLayerTextureMapper.h:82
> + virtual bool addAnimation(const KeyframeValueList&, const IntSize& /*boxSize*/, const Animation*, const String& /*keyframesName*/, double /*timeOffset*/);
No need to do /*boxSize*/, just write boxSize
> Source/WebCore/platform/graphics/texmap/TextureMapperNode.cpp:68
> + void markTextureUsage(BitmapTexture* texture)
mark usage? shouldnt it have a bool then? what about markTextureUsed ?
So this method finds the texture, removes it and prepends it? I guess we need to find a better name for the method
> Source/WebCore/platform/graphics/texmap/TextureMapperNode.cpp:162
> +#if TEXTURE_MAPPER_MINIMAL_COMPUTATIONS
would we add all this TEXTURE_MAPPER_MINIMAL_COMPUTATIONS in a separate patch?
> Source/WebCore/platform/graphics/texmap/TextureMapperNode.cpp:270
> +static const float gTileDimension = 1024.0;
Maybe add to the top? in an empty namespace?
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list