[Webkit-unassigned] [Bug 60010] [Chromium]Add clear_autofill flag to hide autofill popup without clear field.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun May 8 20:36:16 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=60010





--- Comment #14 from Naoki Takano <takano.naoki at gmail.com>  2011-05-08 20:36:16 PST ---
Ilya,

Thank you for your review.

But, as I wrote in Chromium LC, there might have some problem.

So the current flow is
1, Autofill overwrap the field and show the completion. Here the node color is yellow.
2, The user selects the range in the yellow field.
3, The user start dragging.
4, Accept the completion and the yellow field is gone.
5, The user drops the text to another field.
6, But the original field stays the accepted text. (Is this Ok???)

The reason why I ask you about 6 is this dragged text should be gone from the original filed. But still it stays as is.

Maybe when staring dragging, we have to replace the dragged node from original yellow field to white accepted field, don't we?

If so, we have to do more tweaking when starting dragging...

Thanks,

(In reply to comment #13)
> (From update of attachment 92677 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=92677&action=review
> 
> This looks ok to me, but should definitely get looked at by one of the WebKit API guardians.
> 
> > Source/WebCore/ChangeLog:5
> > +        [Chromium]Add clear_autofill flag to hide autofill popup without clear field.
> 
> nit: This description is out of sync with the code changes.
> 
> > Source/WebKit/chromium/public/WebView.h:301
> > +    virtual void acceptCurrectAutoFilled() = 0;
> 
> nit: Is there any reason not to name this more generally, e.g. """ acceptSelectedPopupItem() """ ?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list