[Webkit-unassigned] [Bug 60269] [Windows, WinCairo] Implement ability to add C++ event listeners to html dom elements and dom window

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri May 6 07:45:45 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=60269





--- Comment #14 from Adam Roben (:aroben) <aroben at apple.com>  2011-05-06 07:45:45 PST ---
(In reply to comment #5)
> By the way, I think "CPPEventListener" is a bad name. The listener type should be named after the environment in which it will be used, not the programming language. We have lots of event listeners that are implemented in C++.
> 
> I would suggest COMEventListener, or something similar.

A more typical name for a class in WebKit would be "WebEventListener".

(In reply to comment #12)
> (In reply to comment #11)
> > > Are we just not understanding how this is meant to be connected to WebCore?
> > 
> > First, please realize that a lot of this was already implemented with empty stubs when I got to it. I'm just trying to fill it out like I imagine the original guy would have. I think the idea is that an end user would only see the COM interfaces, i.e. IDOMEventTarget, IDOMEventListener, presumably so that the interfaces can be accessed via non-c++ functionality as well as c++ functionality. 
> 
> Right -- I understand you are working with the existing stubs.  I just meant that I don't get why you were forced to go through an extra layer to connect up to WebCore.  This should work along the lines of WebHistory or one of the other API calls, where the COM object is converted internally to the correct WebCore type.
> 
> I guess you are basically creating this layer, though I would have thought that WebCore would already have had an analogous object that could be filled in with the contents of the IDOMEventListener such that it would get triggered appropriately.

I think the approach taken in this patch makes sense. We do similar things in other parts of the WebKit API.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list