[Webkit-unassigned] [Bug 59143] Need populate touch-icon url to FrameLoaderClient

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue May 3 10:57:50 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=59143


David Kilzer (ddkilzer) <ddkilzer at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #92082|review?                     |review-
               Flag|                            |




--- Comment #15 from David Kilzer (ddkilzer) <ddkilzer at webkit.org>  2011-05-03 10:57:50 PST ---
(From update of attachment 92082)
View in context: https://bugs.webkit.org/attachment.cgi?id=92082&action=review

r- to fix the FeatureDefines.xcconfig issue, remove the conflict markers, renaming/sharing getIconIndex() in IconURL.h, fix indentation issues and fix "didGot" variable names.  I think one more patch should do it!

> Source/WebCore/ChangeLog:7154
> +>>>>>>> .r84917

Please remove the conflict marker.

> Source/WebCore/Configurations/FeatureDefines.xcconfig:120
> +ENABLE_TOUCH_ICON_LOADING = ;

Changes to FeatureDefines.xcconfig need to be copied to all four locations:

JavaScriptCore/Configurations/FeatureDefines.xcconfig
WebCore/Configurations/FeatureDefines.xcconfig
WebKit/mac/Configurations/FeatureDefines.xcconfig
WebKit2/Configurations/FeatureDefines.xcconfig

> Source/WebCore/dom/Document.cpp:341
> +static size_t getIconIndex(IconType type)

Nit: I would call this toIconIndex() instead of getIconIndex() since it's a conversion method, not a true "getter".

> Source/WebCore/dom/Document.cpp:347
> +        break;

Nit: You could use early returns here as well, but it's not necessary.

> Source/WebCore/dom/Document.cpp:4400
> +    if (!iconURL(iconType).m_iconURL.isValid())

Why did this change from an isEmpty() check to isValid() check?

> Source/WebCore/loader/DocumentLoader.cpp:82
> +static size_t getIconIndex(IconType type)

Nit: This should also be named toIconIndex().

This should go in IconURL.h since it's much closer to IconType and ICON_COUNT, and then you can share the implementation in DocumentLoader.cpp and Document.cpp.  There's no need to duplicate this code.

I wouldn't worry about the name of the file being "IconURL.h" unless you can come up with a better one.

> Source/WebCore/loader/DocumentLoader.cpp:697
> +            m_iconURLs[getIconIndex(url.m_iconType)] = url;

Weird indentation here.  Please fix.

> Source/WebCore/loader/FrameLoader.cpp:479
> +            iconURLs.append(getDefaultIconURL(Favicon));

Weird indentation here.  Please fix.

> Source/WebCore/loader/FrameLoader.cpp:482
> +    bool didGotPrecomposedIcon = false;

"didGot" should be changed to "have" in didGotPrecomposedIcon and didGotTouchIcon.

> Source/WebCore/loader/FrameLoader.cpp:499
> +bool FrameLoader::fillIconURL(IconType iconType, Vector<IconURL>* iconURLs)

Nit: addIconURL() seems better than fillIconUURL(), but the current name is fine.

> Source/WebKit/chromium/ChangeLog:637
> +>>>>>>> .r84917

Please remove the conflict marker.

> Source/WebKit/mac/ChangeLog:378
> +>>>>>>> .r84917

Please remove the conflict marker.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list