[Webkit-unassigned] [Bug 59190] Support for alignment for the Sun/Oracle Studio compilers
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Sun May 1 14:50:32 PDT 2011
https://bugs.webkit.org/show_bug.cgi?id=59190
Eric Seidel <eric at webkit.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #91170|review? |review-
Flag| |
--- Comment #4 from Eric Seidel <eric at webkit.org> 2011-05-01 14:50:32 PST ---
(From update of attachment 91170)
View in context: https://bugs.webkit.org/attachment.cgi?id=91170&action=review
> Source/JavaScriptCore/wtf/Vector.h:62
> + AlignedBufferChar *buffer()
Style. * always pins to the type, not the name in WebKit.
> Source/JavaScriptCore/wtf/Vector.h:64
> + AlignedBufferChar *ptr = oversizebuffer;
style again.
> Source/JavaScriptCore/wtf/Vector.h:66
> + ptr += 64 - (reinterpret_cast<size_t>(ptr) & 0x3f);
> + return ptr;
I'm not sure why this is written out in 3 lines, seems to be a single-line worth of code. I don't think the locals help readability here.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list