[Webkit-unassigned] [Bug 56717] [Qt] Clean up redirection logic in QNetworkReplyHandler

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Mar 19 15:59:33 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=56717





--- Comment #4 from Kenneth Rohde Christiansen <kenneth at webkit.org>  2011-03-19 15:59:33 PST ---
(From update of attachment 86273)
View in context: https://bugs.webkit.org/attachment.cgi?id=86273&action=review

>> Source/WebCore/platform/network/qt/QNetworkReplyHandler.cpp:420
>> +    if (m_redirectionTries == 0) { // 10 or more redirections to the same url is considered infinite recursion
> 
> Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]

When 10 is defined as a static variable at the top, maybe it is bad to mention 10 here?

> Source/WebCore/platform/network/qt/QNetworkReplyHandler.cpp:421
> +        ResourceError error(newUrl.host(), 400 /*bad request*/,

Don't we have defines for 400 etc somewhere?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list