[Webkit-unassigned] [Bug 56344] Leaks Viewer should show how many bytes were leaked, not just how many allocations

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Mar 17 23:35:51 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=56344


Joseph Pecoraro <joepeck at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #86139|review?                     |review+
               Flag|                            |




--- Comment #3 from Joseph Pecoraro <joepeck at webkit.org>  2011-03-17 23:35:51 PST ---
(From update of attachment 86139)
View in context: https://bugs.webkit.org/attachment.cgi?id=86139&action=review

r=me, Nice!

> Tools/BuildSlaveSupport/build.webkit.org-config/public_html/LeaksViewer/LeaksParserWorker.js:39
> +            var match = /Leak:.*\ssize=(\d+)\s/.exec(line);

Nit: It might be worth adding a start anchor? /^Leak.../
I don't think you'd ever get a false positive with the '=' string, but it might help matching against long lines.

> Tools/BuildSlaveSupport/build.webkit.org-config/public_html/LeaksViewer/LeaksParserWorker.js:88
> +                    childNode.selfTime += leak.size;
> +                childNode.totalTime += leak.size;
> +                ++childNode.numberOfCalls;

These property names no longer make sense, and could be renamed
in the Worker code and converted later. But I understand your concerns
about performance. So I'm okay with these.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list