[Webkit-unassigned] [Bug 56052] percentages are incorrectly rounded in WebKit
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Fri Mar 11 13:24:14 PST 2011
https://bugs.webkit.org/show_bug.cgi?id=56052
Dave Hyatt <hyatt at apple.com> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #85482|review?, commit-queue? |review-, commit-queue-
Flag| |
--- Comment #7 from Dave Hyatt <hyatt at apple.com> 2011-03-11 13:24:14 PST ---
(From update of attachment 85482)
View in context: https://bugs.webkit.org/attachment.cgi?id=85482&action=review
> Source/WebCore/rendering/AutoTableLayout.cpp:272
> + // if there was no remaining percent, maxWidth is invalid.
> + if (!remainingPercent && maxNonPercent)
> + maxWidth = intMaxForLength;
This seems like a logic change... is there a test to go with it?
> Source/WebCore/rendering/FixedTableLayout.cpp:239
> + float totalRawPercent = 0;
Seems like this could be renamed to remove the "Raw" word.
> LayoutTests/ChangeLog:8
> + * platform/mac/fast/css/percentage-non-integer-expected.txt:
Missing a pixel result for the test?
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list