[Webkit-unassigned] [Bug 49345] Add Support to WebCore to optionally call an optional platform-specific gesture recognizer

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Mar 10 13:58:12 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=49345





--- Comment #45 from Robert Kroeger <rjkroege at chromium.org>  2011-03-10 13:58:11 PST ---
(From update of attachment 82977)
View in context: https://bugs.webkit.org/attachment.cgi?id=82977&action=review

>> Source/WebCore/ChangeLog:5
>> +        Add Support to WebCore to optionally call a platform-specific gesture recognizer
> 
> Support -> support

Done

>>> Source/WebCore/platform/PlatformGestureRecognizer.h:56
>>> +    virtual bool processTouchEventForGesture(const PlatformTouchEvent& event, EventHandler* source, bool handled) = 0;
>> 
>> The parameter name "event" adds no information, so it should be removed.  [readability/parameter_name] [5]
> 
> Please remove "event" as per style bot advice.

Done.

>> Source/WebCore/platform/PlatformGestureRecognizer.h:60
>> +PlatformGestureRecognizer* createPlatformGestureRecognizer();
> 
> I prefer a static class method. static PlatformGestureRecognizer* PlatformGestureRecognizer::create();

Done.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list