[Webkit-unassigned] [Bug 55440] improve layout performance by reducing the traversal time of the floating objects
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Fri Mar 4 12:06:12 PST 2011
https://bugs.webkit.org/show_bug.cgi?id=55440
Darin Adler <darin at apple.com> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #84682|review?, commit-queue? |review+, commit-queue+
Flag| |
--- Comment #15 from Darin Adler <darin at apple.com> 2011-03-04 12:06:11 PST ---
(From update of attachment 84682)
View in context: https://bugs.webkit.org/attachment.cgi?id=84682&action=review
Can we double check that increase/decrease is called in all the right places?
I’m going to say review+ even though I think we may want a little more refinement.
> Source/WebCore/rendering/RenderBlock.cpp:6243
> +inline void RenderBlock::FloatingObjects::clear()
If these are marked inline, I think they need to be in the file *before* the first call to the function. Otherwise on at least some compilers I think this won’t be inlined.
> Source/WebCore/rendering/RenderBlock.cpp:6250
> +inline void RenderBlock::FloatingObjects::increaseObjectsCount(FloatingObject::Type type)
Ditto.
> Source/WebCore/rendering/RenderBlock.cpp:6258
> +inline void RenderBlock::FloatingObjects::decreaseObjectsCount(FloatingObject::Type type)
Ditto.
> Source/WebCore/rendering/RenderBlock.h:721
> + FloatingObjects()
> + : m_leftObjectsCount(0)
> + , m_rightObjectsCount(0)
> + {
> + }
Ideally I’d like to see this function body inside the cpp file too; I think the class is easier to read without the function body here.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list