[Webkit-unassigned] [Bug 55603] [GTK] Implement the next bit of the TextInputController (hasMarkedText and markedRange)
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Fri Mar 4 08:51:25 PST 2011
https://bugs.webkit.org/show_bug.cgi?id=55603
--- Comment #8 from Carlos Garcia Campos <cgarcia at igalia.com> 2011-03-04 08:51:25 PST ---
(In reply to comment #7)
> (From update of attachment 84590 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=84590&action=review
>
> >> Source/WebKit/gtk/WebCoreSupport/DumpRenderTreeSupportGtk.cpp:527
> >> +
> >
> > You should move the line *start = *length = 0; after the g_return_val_if_fail(start && length, false);
>
> I feel that the method should return conssitent values when it fails. Is there a particular reason it's better to move it down? Externally the user of the method couldn't know if it returned false because of a bad argument or one of the following runtime situations.
The macro checks that valid pointers have been passed, so you shouldn't use the pointers before it.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list