[Webkit-unassigned] [Bug 54795] [Chromium] Autocomplete suggestion extends out of window (and onto second monitor)

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Mar 1 00:32:11 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=54795





--- Comment #5 from Naoki Takano <takano.naoki at gmail.com>  2011-03-01 00:32:11 PST ---
Ilya,

Thank you for your review.

(In reply to comment #3)
> (From update of attachment 84189 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=84189&action=review
> 
> I am not a WebKit reviewer, but here are my thoughts:
> 
> > Source/WebCore/ChangeLog:8
> > +        Implement width clip logic according to browser screen width and popup window width. This fix is enough for Win and Mac, but there is a problem in Linux. Because WebScreenInfoFactory::screenInfo() can get only merged screen size, not the screen size where the browser exits.
> 
> nit: exits => exists
Yes, this is typo.

> > Source/WebCore/ChangeLog:10
> > +        Test: fast/canvas/2d.composite.globalAlpha.fillPath.html and canvas/philip/tests/2d.composite.globalAlpha.fill.html with --accelerated-2d-canvas. With multiple screens and submit long input string first. And check the popup window size after that.
> 
> I don't understand why tests and fast/canvas would be relevant here.  I would just leave out this line, and instead include a link above to the Chromium bug.
I completely copy&paste wrong text. I'll fix it.

> > Source/WebCore/platform/chromium/PopupMenuChromium.cpp:364
> > +            if (widgetRect.maxX() > screen.maxX())
> > +                widgetRect.setWidth(screen.maxX() - widgetRect.x());
> 
> nit: Should this be an "else if"?
Yes, you are right.

> > Source/WebCore/platform/chromium/PopupMenuChromium.cpp:386
> > +                int w = widgetRect.width();
> 
> nit: Please name this variable "width"
Ok,

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list