[Webkit-unassigned] [Bug 63481] Bring V8's SerializedScriptValue implementation up to date

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jun 30 23:29:45 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=63481





--- Comment #8 from Dmitry Lomov <dslomov at google.com>  2011-06-30 23:29:45 PST ---
(In reply to comment #6)
> Created an attachment (id=99184)
 --> (https://bugs.webkit.org/attachment.cgi?id=99184&action=review) [details]
> Address comments; handle old wire format.

View in context: https://bugs.webkit.org/attachment.cgi?id=99184&action=review

Few more comments, focusing on tests. I'll do another pass on tests later - the coverage looks solid, but I want to think of it a bit more.
What is the story for modified layout tests and their expectations on non-V8 bindings?

> LayoutTests/ChangeLog:7
> +        - Introduces the new HTML5 DOM error codes for TIMEOUT_ERR, INVALID_NODE_TYPE_ERR, DATA_CLONE_ERR

Hmm I do not see INVALID_NODE_TYPE_ERR in http://www.whatwg.org/specs/web-apps/current-work/multipage/urls.html#exceptions. Only introduce what you use in this patch
(i.e. just add DATA_CLONE_ERR with its proper code)

> LayoutTests/fast/canvas/webgl/script-tests/array-message-passing.js:25
> +    testFailed(tname + ": expected " + s.byteLength + " bytes, got " + g.byteLength);

Add description to assert message to differentiate between other similar asserts (": expected byteLength " .....)

> LayoutTests/fast/canvas/webgl/script-tests/array-message-passing.js:70
> +    testFailed(tname + ": expected " + s.BYTES_PER_ELEMENT + ", saw " + g.BYTES_PER_ELEMENT);

Add description to the assert: "expected BYTES_PER_ELEMENT" (to differentiate with similar asserts)

> LayoutTests/fast/dom/Window/script-tests/postmessage-test.js:118
> +        if (message == "evalThunk") {

Why this is an if in default: case and not a separate case?

> LayoutTests/fast/dom/Window/script-tests/postmessage-test.js:145
> +window.tryPostMessage = function(message, shouldThrow, expected, expectedException) {

Rename expectedException into expectedExceptionOrEvalThunk. 
Then in the beginning of the function add:
  if (expected == "evalThunk") {
     var evalThunk = expectedExceptionOrEvalThunk; 
  }
  else {
     var expectedException = expectedExceptionOrEvalThunk
  }

Use these variables henceforth.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list