[Webkit-unassigned] [Bug 63706] [GTK] Implement drag and drop support in WebKit2

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jun 30 08:46:42 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=63706





--- Comment #6 from Martin Robinson <mrobinson at webkit.org>  2011-06-30 08:46:43 PST ---
(From update of attachment 99291)
View in context: https://bugs.webkit.org/attachment.cgi?id=99291&action=review

Looks good. Definitely need to use a PassRefPtr below. I'll do a full review later!

>> Source/WebKit2/Shared/gtk/ArgumentCodersGtk.cpp:113
>> +static bool decodeDataObject(ArgumentDecoder* decoder, RefPtr<DataObjectGtk>& dataObject)
> 
> The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]

It's pretty weird to pass a reference to a RefPtr here. You should just use a PassRefPtr.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list