[Webkit-unassigned] [Bug 62628] [EFL] Crash when running EWebLauncher

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jun 23 06:32:07 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=62628





--- Comment #27 from Ryuan Choi <ryuan.choi at samsung.com>  2011-06-23 06:32:06 PST ---
(In reply to comment #26)
> (In reply to comment #25)
> > (In reply to comment #24)
> > > (From update of attachment 98089 [details] [details] [details])
> > > Could you rename m_hasRepresentation to something else?
> > 
> > Not that I disagree, but may I ask why? It's what chromium, gtk and qt use. mac, OTOH, uses representationFinishedLoading.
> 
> question is: what has a representation? representation of what?

As my poor reading of mac port,
makeRepresentation() create representation which contains MIMEType and whether plugins allowed.
(WebHTMLRepresentation? I am not sure.)

When finishedLoading is called, representation checks whether it is pluginView, whether it is DisplayingWebArchive and so on. (Below code)

(in WebHTMLRepresentation.mm)
- (void)finishedLoadingWithDataSource:(WebDataSource *)dataSource
{
    WebFrame* webFrame = [dataSource webFrame];

    if (_private->pluginView) {
        [_private->manualLoader pluginViewFinishedLoading:_private->pluginView];
        return;
    }   

    if (!webFrame)
        return;

    if (![self _isDisplayingWebArchive]) {
        // Telling the frame we received some data and passing nil as the data is our
        // way to get work done that is normally done when the first bit of data is
        // received, even for the case of a document with no data (like about:blank).
        [webFrame _commitData:nil];
    }   

    WebView *webView = [webFrame webView];
    if ([webView isEditable])
        core(webFrame)->editor()->applyEditingStyleToBodyElement();
}

WebKit/EFL (and other ports also) doesn't have representaion and just checked similar in FrameLoaderClient::finishedLoading.

If you want, I can change it to m_hasDocumentRepresentation or m_hasHTMLRepresentation or your suggestion.
But now, I'd like to keep current name like other ports except Mac port.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list