[Webkit-unassigned] [Bug 43446] [EFL] Exporting JavaScript objects for EFL port

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jun 22 13:23:51 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=43446





--- Comment #25 from Flavio Ceolin <flavio.ceolin at profusion.mobi>  2011-06-22 13:23:50 PST ---
(In reply to comment #23)
> (From update of attachment 97605 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=97605&action=review
> 
> > Source/WebKit/efl/ewk/ewk_js.cpp:21
> > +
> 
> You don't need to add empty line to here.

Fixed

> 
> > Source/WebKit/efl/ewk/ewk_js.cpp:93
> > +       return (Ewk_JS_Object*)np_obj;
> 

Fixed

> Please adhere indentation.
> 
> > Source/WebKit/efl/ewk/ewk_js.cpp:96
> > +        return 0;
> 
> ditto.
>
I couldn't see this mistake. The indentation seems to be right.

> > Source/WebKit/efl/ewk/ewk_js.cpp:714
> > +#else
> 
> Personally, I don't like to make dummy functions for macro. Other ewk functions are using macro its inside for disabling macro.
> 
> const char *ewk_settings_web_database_path_get(void)
> {
> #if ENABLE(DATABASE)
>     return _ewk_default_web_database_path;
> #else
>     return 0;
> #endif
> }
> 
> > Source/WebKit/efl/ewk/ewk_private.h:1
> > +
> 
> Please remove empty line.

Fixed

I sent a new patch fixing the mistakes. About the dummy functions, my point is 
that will be necessary too many #if without them. To my mind the dummy 
functions is better in this case (although I don't like too). If you still 
prefer the #if inside the functions I can send a new patch.

Thanks for the advices :)

Regards, Ceolin

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list