[Webkit-unassigned] [Bug 63164] New: CompositeEditingCommand::splitTreeToNode should split to a position instead.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jun 22 11:55:35 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=63164

           Summary: CompositeEditingCommand::splitTreeToNode should split
                    to a position instead.
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: Unspecified
        OS/Version: Unspecified
            Status: UNCONFIRMED
          Severity: Normal
          Priority: P2
         Component: HTML Editing
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: sullivan at chromium.org
                CC: rniwa at webkit.org


The method should be renamed splitTree(Position& start, Node*end, enum shouldSplitAncestor).

Looking at the callsites makes it clear why we really should to split to a position:
* Most of them actually split to a position.containerNode() or position.deprecatedNode() already
* InsertListCommand::doApply has a lot of logic for picking the node to split to which would be greatly simplified by splitting to a position
* ReplaceSelectionCommand::insertAsListItems has to do some extra splitting of text nodes that would happen automatically in splitNodeToPosition
* InsertParagraphSeparatorCommand::doApply() recently regressed because sometimes it would pick the wrong node to split to from the position.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list