[Webkit-unassigned] [Bug 62709] [EFL] Add GraphicsContext3DEfl for WebGL and accelerated compositing

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jun 22 07:44:51 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=62709


Leandro Pereira <leandro at profusion.mobi> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #98116|review?                     |review-
               Flag|                            |




--- Comment #10 from Leandro Pereira <leandro at profusion.mobi>  2011-06-22 07:44:50 PST ---
(From update of attachment 98116)
View in context: https://bugs.webkit.org/attachment.cgi?id=98116&action=review

This looks like a huge wrapper class; isn't it possible to share most of this code with other ports, as there are few references to Evas and such?

> Source/WebCore/platform/graphics/efl/GraphicsContext3DEfl.cpp:35
> +    bool renderDirectlyToEvasGLObject = (renderStyle == RenderDirectlyToHostWindow) ? true : false;

No need to use a ternary operator here; comparisons already returns a boolean.

> Source/WebCore/platform/graphics/efl/GraphicsContext3DEfl.cpp:142
> +    m_internal->bufferData(target, size, /* data */ 0, usage);

Is this comment really needed?

> Source/WebCore/platform/graphics/efl/GraphicsContext3DEfl.cpp:167
> +    m_internal->clearColor(r, g, b, a);

I'd use more descriptive names here.

> Source/WebCore/platform/graphics/efl/GraphicsContext3DEfl.cpp:177
> +    m_internal->clearStencil(s);

Ditto.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list