[Webkit-unassigned] [Bug 61344] --webkit-visual-word does not work in multi-line

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jun 20 18:56:06 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=61344





--- Comment #8 from Ryosuke Niwa <rniwa at webkit.org>  2011-06-20 18:56:06 PST ---
(From update of attachment 96341)
View in context: https://bugs.webkit.org/attachment.cgi?id=96341&action=review

Great!  New patch looks much better.  But it'll be nice if rendering experts like mitz or dhyatt could give us some feedback.

> Source/WebCore/editing/htmlediting.h:144
> +inline Position createPosition(Node* node, int offset)

This function name sounds too general.  How about createPosiitonAvoidingIgnoredNode?

> Source/WebCore/editing/visible_units.cpp:1506
> +        RenderObject* previousBlockRenderer = renderer->previousSibling();
> +        while (previousBlockRenderer) {
> +            const RenderBlock* blockWithLineBoxes = lastChildBlockWithLineBoxes(toRenderBlock(previousBlockRenderer));
> +            if (blockWithLineBoxes)
> +                return blockWithLineBoxes->lastRootBox();
> +
> +            previousBlockRenderer = previousBlockRenderer->previousSibling();
> +        }

It seems like this loop is almost identical to the one in lastChildBlockWithLineBoxes. Can we combine these two loops?

> Source/WebCore/editing/visible_units.cpp:1564
> +    const InlineFlowBox* leftLineBox = (blockDirection == LTR) ? rootBox->prevLineBox() :
> +                                                                 rootBox->nextLineBox();

I wonder it makes a sense to add a helper function on InlineTextBox.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list