[Webkit-unassigned] [Bug 62899] [UNIX] Don't use WebCore::PluginPackage to get plugin information

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jun 20 09:57:35 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=62899


Martin Robinson <mrobinson at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #97790|review?                     |review+
               Flag|                            |




--- Comment #3 from Martin Robinson <mrobinson at webkit.org>  2011-06-20 09:57:35 PST ---
(From update of attachment 97790)
View in context: https://bugs.webkit.org/attachment.cgi?id=97790&action=review

Looks good, but please take a look at the following suggestions before landing.

> Source/WebKit2/Shared/Plugins/Netscape/x11/NetscapePluginModuleX11.cpp:104
> +        Vector<String> mime;

Maybe call this something like mimeTypeParts.

> Source/WebKit2/Shared/Plugins/Netscape/x11/NetscapePluginModuleX11.cpp:116
> +        Vector<String> extensions;
> +        if (mime.size() > 1) {
> +            mime[1].split(UChar(','), false, extensions);
> +            mimeInfo.extensions = extensions;

Can you just pass mimeInfo.extensions to the split call here?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list