[Webkit-unassigned] [Bug 62838] [Qt] [WK2] Add drag and drop support

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jun 17 02:11:01 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=62838





--- Comment #2 from Kenneth Rohde Christiansen <kenneth at webkit.org>  2011-06-17 02:11:01 PST ---
(From update of attachment 97536)
View in context: https://bugs.webkit.org/attachment.cgi?id=97536&action=review

> Source/WebCore/platform/DragData.h:127
> +    DragData() {}

Need a space in there :-)

> Source/WebKit2/Shared/qt/ArgumentCodersQt.cpp:33
> +typedef HashMap<String , Vector<uint8_t> > MimeDataHashMap;

shouldnt MIME be uppercase?

> Source/WebKit2/Shared/qt/ArgumentCodersQt.cpp:47
> +    encoder->encodeBool(true);

What is this for? /* platformData */ ? hasPlatformData?

> Source/WebKit2/Shared/qt/ArgumentCodersQt.cpp:53
> +        Vector<uint8_t> vdata;

vdata? vector of data? maybe we can find a better name

> Source/WebKit2/Shared/qt/ArgumentCodersQt.cpp:55
> +        uint8_t* data = (uint8_t*)(bytes.data());

Why are you not using C++ casts?

> Source/WebKit2/UIProcess/API/qt/qwkpage.cpp:898
> +    QWidget* widget = view->scene()->views()[0];

Didnt we have a convenience method for getting the right view? or maybe that is only on our branch?

> Source/WebKit2/WebProcess/WebPage/WebPage.cpp:1696
> +    if (data)
> +        delete data;

no, that if is not needed in C++

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list