[Webkit-unassigned] [Bug 62480] WebKit2: improve first page load speed by adding API to launch WebProcess earlier

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jun 10 18:15:52 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=62480


Sam Weinig <sam at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #96793|review?                     |review-
               Flag|                            |




--- Comment #2 from Sam Weinig <sam at webkit.org>  2011-06-10 18:15:53 PST ---
(From update of attachment 96793)
View in context: https://bugs.webkit.org/attachment.cgi?id=96793&action=review

> Source/WebKit2/UIProcess/API/C/WKContext.cpp:104
> +    toImpl(contextRef)->ensureWebProcess();

This should call a function on WebContext that matches the suffix of the API function call and the logic should be in WebContext.

> Source/WebKit2/UIProcess/API/C/WKContext.h:116
> +WK_EXPORT void WKContextLaunchInjectedBundle(WKContextRef context);

This isn't a good name for this.  How about WKContextWarmInitialProcess(...).  I also think this should go in WKContextPrivate.h

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list