[Webkit-unassigned] [Bug 61995] Accessibility description for an element should make use of aria-labelledby.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jun 8 00:46:08 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=61995





--- Comment #8 from chris fleizach <cfleizach at apple.com>  2011-06-08 00:46:08 PST ---
(From update of attachment 96391)
View in context: https://bugs.webkit.org/attachment.cgi?id=96391&action=review

> Source/WebCore/accessibility/AccessibilityRenderObject.cpp:1356
> +        return ariaLabelledBy;

This is used in title();
String ariaLabel = ariaLabeledByAttribute(); 

I think we need to re-organize what goes into title vs. description. I think we need to rename title to accessibilityName and use accessibilityDescription for aria-describedby

But that's a big job. You should remove the call in ::title() so that it's only in ariaAXDescription.

I'd guess you'd have some Mac test failures with this. I also suspect these test won't pass on GTK and Win, since they probably return different prefixes for title and description.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list