[Webkit-unassigned] [Bug 54752] [EFL] Soup authentication feature implementation

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jun 6 06:50:10 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=54752





--- Comment #13 from Kamil Blank <k.blank at samsung.com>  2011-06-06 06:50:09 PST ---
Thank you for the review. 
I followed your suggestions and prepared new patch.

I also added code inside ewk_auth_soup.cpp in case of unset callback - to free memory and unpause soup message.

(In reply to comment #12)
> (From update of attachment 95871 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=95871&action=review
> 
> I couldn't figure out how this would work. Could you please provide a simple explanation of the expected flow?

Let's say that we've already got some functionality implemented to get username/password which is of type Ewk_Show_Auth_Dialog_Callback:
  static void auth_dialog_show(const char* realm, const char* uri, void* data);

First, application should call ewk_auth_show_dialog_callback_set(auth_dialog_show) to let WebKit know which function should be called when authentication required.
This function is responsible for getting username/password from user and pass them through ewk_auth_credentials_set(). 

> > Source/WebKit/efl/ewk/ewk_auth.cpp:27
> > +ewk_auth_show_dialog_callback g_auth_show_dialog_callback = 0;
> 
> Structures/typedefs in EFL are named Using_A_Combination_Of_Camel_Case_And_Underscores. Also, this variable should be static and there's no need to prepend the name with "g_" to denote it is a global variable.

I moved this variable inside ewk_auth_soup.cpp

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list