[Webkit-unassigned] [Bug 64355] [Soup] Cannot override default max-conns and max-conns-per-host Soup Session settings
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Jul 26 14:37:44 PDT 2011
https://bugs.webkit.org/show_bug.cgi?id=64355
Martin Robinson <mrobinson at webkit.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #102030| |review-
Flag| |
--- Comment #29 from Martin Robinson <mrobinson at webkit.org> 2011-07-26 14:37:44 PST ---
(From update of attachment 102030)
View in context: https://bugs.webkit.org/attachment.cgi?id=102030&action=review
This looks like a good solution to me. Thanks for working on it. If you can get some buy-in from Sergio and some of the others who've commented here. I'll r+ this with the small fixes I suggested below.
> Source/WebCore/platform/network/soup/ResourceHandleSoup.cpp:849
> + initData = g_object_get_data(G_OBJECT(session), "webkit-init");
I'd prefer smething like this:
static SoupSession* session = 0;
if (!session) {
session = soup_session_async_new();
g_object_set(...);
}
Depending on "webkit-init" adds a dependency on some other random bit of the code.
> Source/WebCore/platform/network/soup/ResourceHandleSoup.cpp:850
> + if (!initData)
You should use curly braces on this if block, since the contents span more than one line.
>> Source/WebCore/platform/network/soup/ResourceHandleSoup.cpp:854
>> + NULL);
>
> Use 0 instead of NULL. [readability/null] [5]
You can ignore this failure. The style-bot isn't smart enough to understand that the NULL is necessary because the g_object_set is on another line.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list