[Webkit-unassigned] [Bug 37674] Implement sizes attribute for link tag from HTML5
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Fri Jul 22 10:53:44 PDT 2011
https://bugs.webkit.org/show_bug.cgi?id=37674
--- Comment #23 from Rachel Blum <groby at chromium.org> 2011-07-22 10:53:44 PST ---
> the bots are all confused, probably need to re-run the patch.
Yes, a merge conflict. Resolved locally, testing right now.
> Let's also test setting the sizes attribute from script.
That's already in there, see icon-sizes-property.html:23-25
icon.sizes="10x10 20x20 30x30 40x40";
shouldEvaluateTo('icon.sizes.length',4);
shouldBeEqualToString('icon.sizes.value',"10x10 20x20 30x30 40x40");
> Could we just override validateToken and not do the fooInternal dance?
We possibly could, except it's currently a static on DOMTokenList, not a member. I'll check if there's any reason to keep it that way, otherwise it just earned itself a 'virtual' ;)
> Are we really supposed to throw SYNTAX_ERR in these cases?
That's how I read the spec - can't have more than one 'x'/'X', and it must separate two numbers. It's not really an invalid character per se.
> This seems inefficient. It's almost like SpaceSplitString wants to have a validating function parameter.
The entire chain right now is inefficient - SizesList::validateTokenInternal also traverses the token twice. On the upside, it's a clear separation of responsibilities.
> Should we be more specific in naming, like IconSizeList?
Probably a better name, so will do.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list