[Webkit-unassigned] [Bug 64858] input[type='number'] with step="any" suffers from step mismatch.
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Wed Jul 20 04:02:59 PDT 2011
https://bugs.webkit.org/show_bug.cgi?id=64858
Kent Tamura <tkent at chromium.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #101446|review? |review-
Flag| |
--- Comment #2 from Kent Tamura <tkent at chromium.org> 2011-07-20 04:02:59 PST ---
(From update of attachment 101446)
View in context: https://bugs.webkit.org/attachment.cgi?id=101446&action=review
> Source/WebCore/html/HTMLInputElement.cpp:429
> + // If step is not "any", the value should by aligned to the step.
> + const AtomicString& stepString = fastGetAttribute(stepAttr);
> + if (!equalIgnoringCase(stepString, "any")) {
This comment is not helpful. We avoid comments about "what we do here". This comment should be removed.
Also, this comment has a typo; by -> be.
In this case, you might want to make a function named alignValueForStep(...) for readability.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list