[Webkit-unassigned] [Bug 64786] The value of a number input form continues to increase/decrease even if we disable the input form.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jul 19 20:33:52 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=64786


Kent Tamura <tkent at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #101302|review?                     |review-
               Flag|                            |




--- Comment #11 from Kent Tamura <tkent at chromium.org>  2011-07-19 20:33:52 PST ---
(From update of attachment 101302)
View in context: https://bugs.webkit.org/attachment.cgi?id=101302&action=review

> LayoutTests/fast/forms/spin-button-gets-disabled-or-readonly.html:60
> +        setTimeout(function() {
> +            shouldBeEqualToString('input.value', "1234566");
> +            nextDelayTest();
> +        }, 600);

Why do we wait for 600msec? 
I'm afraid this test will be a very slow test.

> LayoutTests/fast/forms/spin-button-gets-disabled-or-readonly.html:65
> +    input.readOnly = "readonly";

The type of HTMLInputElement::readOnly is boolean, not string.

> LayoutTests/fast/forms/spin-button-gets-disabled-or-readonly.html:72
> +    input.disabled = "disabled";

The type of HTMLInputElement::disabled is boolean, not string.

> LayoutTests/fast/forms/spin-button-gets-disabled-or-readonly.html:81
> +    input.disabled = undefined;
> +    input.readOnly = undefined;

ditto.

> Source/WebCore/ChangeLog:25
> +        (WebCore::HTMLElement::releaseCapture): A virtual method.

"A virtual method." isn't helpful.
We should write what is changed, reasons of the change, or a purpose of the function.

> Source/WebCore/ChangeLog:31
> +        (WebCore::InputType::disabledAttributeChanged): A virtual method.
> +        (WebCore::InputType::readonlyAttributeChanged): A virtual method.

ditto.

> Source/WebCore/html/HTMLElement.h:87
> +    virtual void releaseCapture();
> +

I don't think we need to add this function to HTMLElement.
TextFieldInputType can know m_innerSpinButton type is SpinButtonElement.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list