[Webkit-unassigned] [Bug 57154] [Qt] Make OpenGL symbol resolver transparent
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Jul 19 12:54:21 PDT 2011
https://bugs.webkit.org/show_bug.cgi?id=57154
Noam Rosenthal <noam.rosenthal at nokia.com> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #101209|review? |review-
Flag| |
--- Comment #36 from Noam Rosenthal <noam.rosenthal at nokia.com> 2011-07-19 12:54:21 PST ---
(From update of attachment 101209)
View in context: https://bugs.webkit.org/attachment.cgi?id=101209&action=review
> Source/WebCore/WebCore.pro:3619
> + CONFIG += opengl-shims
Indentation seems a bit off.
> Source/WebCore/platform/graphics/cairo/OpenGLShims.cpp:20
> +#if ENABLE(WEBGL) || (PLATFORM(QT) && USE(TEXTURE_MAPPER_GL))
This is a bit awkward. Maybe add a define QT_OPENGL_SHIMS inside the contains(CONFIG...) clause? Otherwise we repeat the build-time logic that decides whether to use it twice.
> Source/WebCore/platform/graphics/cairo/OpenGLShims.cpp:34
> +#define ASSIGN_FUNCTION_TABLE_ENTRY(FunctionName, success) \
Strange to use uppercase for FunctionName and lowercase for success.
> Source/WebCore/platform/graphics/cairo/OpenGLShims.cpp:46
> + return QGLContext::currentContext()->getProcAddress(QLatin1String(procName));
This doesn't buy you anything. getProcAddress(procName) is essentially the same thing and is somewhat more readable.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list