[Webkit-unassigned] [Bug 64786] The value of a number input form continues to increase/decrease even if we disable the input form.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jul 19 03:06:42 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=64786





--- Comment #4 from Kentaro Hara <haraken at google.com>  2011-07-19 03:06:42 PST ---
(From update of attachment 101288)
View in context: https://bugs.webkit.org/attachment.cgi?id=101288&action=review

>> LayoutTests/ChangeLog:20
>> +        Reviewed by NOBODY (OOPS!).
> 
> This line should be in the next of the bug URL.

Done.

>> Source/WebCore/html/HTMLInputElement.cpp:795
>> +        m_inputType->readonlyAttributeChanged();
> 
> This will make some regressions because HTMLFormControlElement::parseMappedAttribute() won't be called for disabled and readonly.

Removed this method, going away this issue.

>> Source/WebCore/html/TextFieldInputType.cpp:248
>> +    m_innerSpinButton->stopRepeating();
> 
> m_innerSpinButton can be NULL.

Removed this method, going away this issue.

>> Source/WebCore/html/shadow/TextControlInnerElements.cpp:336
>> +}
> 
> How about calling stopRepeatingTimer() in repeatingTimerFired()? If we do so, we don't need to add disabledAttributeChanged() and readonlyAttribtueChanged().

Great idea! But I think that stopRepeatingTimer() is necessary not only in repeatingTimerFired() but also in defaultEventHandler(). There is a possibility that 'mouseup' event happens and then the input form gets enabled again, before the first repeatingTimerFired() is invoked.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list