[Webkit-unassigned] [Bug 63966] [EFL] Add url bar to EWebLauncher.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jul 7 03:30:51 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=63966





--- Comment #7 from Hyerim Bae <hyerim.bae at samsung.com>  2011-07-07 03:30:51 PST ---
Also, if I use 'edje entry' without the 'elementary', It's more complicated than using the 'textblock' directly.
That means I should implement the 'elementary entry widget' with using the 'edje entry'.
It's much more easy to use the 'elementary entry' directly instead, but as you know, the webkit can't has a elementary dependency.

(In reply to comment #6)
> I'll modify what you mentioned below.
> Also, regarding using textblock, you are absolutely right.
> However, the Edje can't receive the user input key value directly as far as I know.
> That's why I used the textblock and handle it manually.
> (In reply to comment #4)
> > Apart from the comments below, I would much rather if the patch was changed to use Edje instead of using textblock directly: most of the code in this patch simply does a lot of manual work which should not be required in an application in the 21st century :)
> > > Tools/ChangeLog:10
> > > +        Then the user can navigate to the site where he or she intends to do.
> > The "do" is not needed here.
> > > Tools/EWebLauncher/main.c:762
> > > +    Evas_Event_Mouse_Down *ev = (Evas_Event_Mouse_Down*) event_info;
> > This kind of cast is not needed.
> > > Tools/EWebLauncher/main.c:952
> > > +            snprintf(full_url, 4096, "http://%s", url);
> > As this code is used in two different places, it would be good to factor it out into a separate function (or even provide it as a utility function in ewk later. eve needs to do the same thing in its code).

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list