[Webkit-unassigned] [Bug 63929] A 'change' event is not triggered on a multiple file form when selected files are changed

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jul 5 19:25:06 PDT 2011


https://bugs.webkit.org/show_bug.cgi?id=63929





--- Comment #10 from Kent Tamura <tkent at chromium.org>  2011-07-05 19:25:06 PST ---
(From update of attachment 99781)
View in context: https://bugs.webkit.org/attachment.cgi?id=99781&action=review

> LayoutTests/ChangeLog:8
> +        the newly selected files, we trigger the 'onchange' event.

nit: 'onchange' is an attribute name. The event name is 'change'.

> LayoutTests/ChangeLog:11
> +
> +        Reviewed by Kent Tamura.
> +

The recent ChangeLog format is:

<summary>
<bug URL>

<Reviewd by>

<details>

Also, don't fill this field while you're asking to review.

> LayoutTests/fast/forms/file-input-change-event.html:15
> +var onChangeCalled;

nit: onChange is an attribute name.
It should be handlerCalled, changeHandlerCalled, changeDispatched, etc.

> Source/WebCore/ChangeLog:12
> +        https://bugs.webkit.org/show_bug.cgi?id=63929
> +
> +        Record previously selected files and then compare them with newly selected files.
> +        If the previously selected files and their order are not equal to those of
> +        the newly selected files, we trigger the 'change' event.
> +
> +        Reviewed by Kent Tamura.
> +
> +        Test: fast/forms/file-input-change-event.html

Should be bug-URL - Reviewd by - Detail - Test: order.

> Source/WebCore/html/FileInputType.cpp:286
> +        for (unsigned i = 0; i < paths.size(); i++) {

We prefer ++i for 'for'.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list