[Webkit-unassigned] [Bug 63709] Disabled or read-only input type=search still allows clicking [x] to clear contents
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Fri Jul 1 05:41:06 PDT 2011
https://bugs.webkit.org/show_bug.cgi?id=63709
Kentaro Hara <haraken at google.com> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #99452|1 |0
is obsolete| |
--- Comment #11 from Kentaro Hara <haraken at google.com> 2011-07-01 05:41:06 PST ---
(From update of attachment 99452)
View in context: https://bugs.webkit.org/attachment.cgi?id=99452&action=review
>> LayoutTests/fast/forms/disabled-search-input-expected.txt:11
>> +PASS Value is "foo".
>
> Test result readability is not good.
> Please show each of test conditions by debug();
Done.
> LayoutTests/fast/forms/disabled-search-input.html:1
> +<!DOCTYPE html>
I renamed the file to search-disabled-readonly.html.
>>> LayoutTests/fast/forms/disabled-search-input.html:8
>>> +<input id="search_input" type="search" />
>>
>> The purpose of the existing test is to check behavior in a case that a disabled search field gets enabled. You must add 'disabled' here.
>
> Also, the existing test clicks the center of the search field in order to get focus, not the cancel button.
Done. I added the test cases for both, i.e. (1) click the center of the form and (2) click the cancel button.
>> LayoutTests/fast/forms/disabled-search-input.html:15
>> +function click(button) {
>
> The argument name 'button' is confusing. It's a position of something.
Done.
>> LayoutTests/fast/forms/disabled-search-input.html:37
>> +}
>
> This function is not needed.
> You can write it as:
> shouldBe('input.value', '"foo"');
Done.
>> LayoutTests/fast/forms/disabled-search-input.html:39
>> +function setInputAttribute(input, value, disabled, readonly) {
>
> Attribute -> Attributes?
Done.
>> LayoutTests/fast/forms/disabled-search-input.html:45
>> + input.removeAttribute("readonly");
>
> Why don't you use input.readOnly = readonly ?
Done.
>> LayoutTests/fast/forms/disabled-search-input.html:50
>> + var cancelButton = searchCancelButtonPosition(input);
>
> 'cancelButton' is not a good name. It's a position, not button.
Done.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list