[Webkit-unassigned] [Bug 51364] Web Inspector: Remote Web Inspector for platform/mac

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jan 19 11:00:48 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=51364





--- Comment #27 from Joseph Pecoraro <joepeck at webkit.org>  2011-01-19 11:00:48 PST ---
(In reply to comment #23)
> (From update of attachment 79448 [details])
> This looks good. Are there any other reasons canBeRemotelyInspected would return
> false that we could want in the future? Is it worth putting a FIXME there?

See: https://bugs.webkit.org/show_bug.cgi?id=51364#c20
A FIXME is a good idea depending on our approach in that bug.

(In reply to comment #24)
> > Source/WebKit/mac/WebInspector/WebInspectorServer.mm:184
> > +        if (!it->second->allowsRemoteInspection())
> 
> If we're using it->second multiple times, is it worth it to pull it out into a local variable?

Sure, I can do that.

> > Source/WebKit/mac/WebInspector/WebInspectorServerConnection.mm:395
> > +        NSLog(@"WebInspectorServerConnection: WebView does not allow remote inspection.");
> 
> Is it useful to print any information about the WebView in this log?

Good point. The others all print the pageId when referring to a Page / WebView,
so I will change this to:

  NSLog(@"WebInspectorServerConnection: WebView for Page (%d) does not allow remote inspection.", pageId);

Also, these logs should eventually turn into error messages sent to the front-end
so that is a good idea. See:
https://bugs.webkit.org/show_bug.cgi?id=51364#c5

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list