[Webkit-unassigned] [Bug 52680] [chromium] Notify WebViewClient when spellcheck state changes

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jan 19 08:41:28 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=52680


Darin Fisher (:fishd, Google) <fishd at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #79425|commit-queue+               |commit-queue-, review-
               Flag|                            |




--- Comment #15 from Darin Fisher (:fishd, Google) <fishd at chromium.org>  2011-01-19 08:41:27 PST ---
(From update of attachment 79425)
View in context: https://bugs.webkit.org/attachment.cgi?id=79425&action=review

> Source/WebKit/chromium/public/WebViewClient.h:191
> +    virtual void continuousSpellCheckingEnabledStateChanged() { }

This function name is a real mouthful.  We also have a naming convention for methods like this, where they start with "didChange" instead.

So, didChangeContinuousSpellCheckingEnabledState would be more consistent.  I still find this method name to be overly verbose.

Also, this method is on WebViewClient.h, and yet the corresponding methods to query the "spellchecking" state lives on WebFrame.
shouldn't this notification method live on WebFrameClient, then?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list