[Webkit-unassigned] [Bug 52352] Style cleanup for WebGLRenderingContext

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jan 14 01:42:23 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=52352





--- Comment #1 from David Levin <levin at chromium.org>  2011-01-14 01:42:23 PST ---
Here's the output from check-webkit-style on that previous patch:

Source/WebCore/html/canvas/WebGLBuffer.h:44:  The parameter name "size" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLBuffer.h:47:  The parameter name "array" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLBuffer.h:48:  The parameter name "array" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLBuffer.h:98:  The parameter name "array" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLBuffer.h:100:  The parameter name "array" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLUniformLocation.h:42:  The parameter name "program" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLUniformLocation.h:49:  The parameter name "program" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:71:  The parameter name "ec" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:73:  The parameter name "ec" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:74:  The parameter name "ec" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:75:  The parameter name "ec" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:76:  The parameter name "ec" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:77:  The parameter name "ec" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:84:  The parameter name "size" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:133:  The parameter name "ec" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:134:  The parameter name "ec" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:151:  The parameter name "ec" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:198:  The parameter name "image" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:200:  The parameter name "canvas" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:202:  The parameter name "video" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:213:  The parameter name "image" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:215:  The parameter name "canvas" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:217:  The parameter name "video" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:219:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:221:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:221:  The parameter name "size" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:222:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:224:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:224:  The parameter name "size" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:225:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:227:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:227:  The parameter name "size" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:228:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:230:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:230:  The parameter name "size" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:231:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:233:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:233:  The parameter name "size" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:234:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:236:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:236:  The parameter name "size" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:237:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:239:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:239:  The parameter name "size" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:240:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:242:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:242:  The parameter name "size" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:243:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:244:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:244:  The parameter name "size" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:245:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:246:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:246:  The parameter name "size" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:247:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:248:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:248:  The parameter name "size" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:255:  The parameter name "size" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:258:  The parameter name "size" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:261:  The parameter name "size" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:264:  The parameter name "size" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:471:  The parameter name "image" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:564:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:565:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:566:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:566:  The parameter name "v" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:566:  The parameter name "size" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:567:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:568:  The parameter name "location" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:568:  The parameter name "v" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:568:  The parameter name "size" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/html/canvas/WebGLRenderingContext.h:577:  The parameter name "size" adds no information, so it should be removed.  [readability/parameter_name] [5]


If you felt it would be faster, you could probably hack up check-webkit-style for your our purposes to remove these names and write out the files again (but that may be more trouble than it is worth).

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list