[Webkit-unassigned] [Bug 44256] [EFL] Private Browsing feature for WebKit-Efl

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jan 6 09:37:34 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=44256


Lucas De Marchi <demarchi at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #77985|commit-queue?               |commit-queue-
               Flag|                            |




--- Comment #28 from Lucas De Marchi <demarchi at webkit.org>  2011-01-06 09:37:34 PST ---
(From update of attachment 77985)
View in context: https://bugs.webkit.org/attachment.cgi?id=77985&action=review

> WebKit/efl/ewk/ewk_settings.cpp:300
> + * Disables/enables memory cache of WebCore.
> + *
> + * @param @c EINA_TRUE if we want to disable WebCore's cache, @c EINA_FALSE if we want to enable.
> + * @return @c EINA_TRUE if cache has been disabled/enabled, @c EINA_FALSE if function can't disable/enable cache.
> + */
> +Eina_Bool ewk_settings_disable_cache_set(Eina_Bool set)

This name is really weird because there are 2 verbs "disable" and "set". Could you rename it to ewk_settings_cache_disabled_set?

> WebKit/efl/ewk/ewk_settings.cpp:307
> +    if (cache->disabled() != set) 

Since this is EAPI, you can't really trust user passed EINA_TRUE or EINA_FALSE. In some places we use to use "set = !!set;". Please either do this or check by "!set"

> WebKit/efl/ewk/ewk_view.h:538
> +EAPI Eina_Bool ewk_view_incognito_browsing_set(Evas_Object *o, Eina_Bool enable);

Follow the other cases on this header: it's Evas_Object* o, not Evas_Object *o

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list