[Webkit-unassigned] [Bug 51382] [Chromium]Issue 60427: Fix popup menu re-positioning when the menu is opened upward, above the corresponding form field. http://crbug.com/60427

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jan 5 17:35:32 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=51382


Kent Tamura <tkent at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #77302|review?                     |review-
               Flag|                            |




--- Comment #27 from Kent Tamura <tkent at chromium.org>  2011-01-05 17:35:32 PST ---
(From update of attachment 77302)
View in context: https://bugs.webkit.org/attachment.cgi?id=77302&action=review

> WebCore/ChangeLog:21
> +010-12-09  Dan Bernstein  <mitz at apple.com>

Do not modify an existing ChangeLog entry.
Do not use TAB characters in ChangeLog.

>> WebCore/platform/chromium/PopupMenuChromium.cpp:343
>>      layout();
> 
> It seems weird to me that layout() -- which seems to have side effects -- is being called from a method named "calculateWidgetRect", which I would expect not to have side effects.

I agree with Ilya.  Side effect in calculateWidgetRect() sounds slightly curious.
Please try removing layout(), and rename it to layoutAndCalculateWidgetRect().

>> WebCore/platform/chromium/PopupMenuChromium.cpp:368
>> +                IntRect windowRect(targetFrameRect.location(), size());
> 
> This line seems unnecessary given that windowRect is computed above.

This "windowRect" hides another "windowRect".  It's bad.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list