[Webkit-unassigned] [Bug 51464] [Qt] document.getElementById(...) doesn't return the right object in combination with QGraphicsWidget

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jan 3 07:40:07 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=51464





--- Comment #6 from Simon Hausmann <hausmann at webkit.org>  2011-01-03 07:40:07 PST ---
(From update of attachment 77761)
View in context: https://bugs.webkit.org/attachment.cgi?id=77761&action=review

I think overall the patch looks good, but I suggest the above renamings/fixes before landing.

> WebCore/platform/Widget.h:239
> +    QObject* qtObject() const;
> +    void setQtObject(QObject*);

I think this property should be called bindingsObject() instead of qtObject. Makes IMHO more sense in the context of WebCore::Widget.

> WebCore/platform/Widget.h:287
> +    QObject* m_qtObject;

I suppose for safety purposes this could be a QWeakPointer.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list