[Webkit-unassigned] [Bug 13807] XML without style should render as syntax-highlighted source

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Feb 25 10:40:33 PST 2011


--- Comment #31 from Vsevolod Vlasov <vsevik at chromium.org>  2011-02-25 10:40:32 PST ---
View in context: https://bugs.webkit.org/attachment.cgi?id=83826&action=review

>> LayoutTests/http/tests/xmlviewer/dumpAsText/xmlviewer-charset-utf8.xml:4
>> +  <utf8>Широкая электрификация южных губерний даст мощный толчок подъёму сельского хозяйства.</utf8>
> One trick I often use is to have "SUCCESS" spelled with Cyrillic "CCE". That way, even a person who doesn't know Russian will be able to see if the results are correct.

Nice trick. Done.

>> Source/WebCore/dom/XMLDocumentParserLibxml2.cpp:1342
>> +            document()->setParsing(false); // Make the doc think it's done, so it will apply xsl sheets.
> Please don't abbreviate "document", and spell "XSL stylesheets".

Not my code actually, but done :)

>> Source/WebCore/xml/XMLTreeViewer.cpp:104
>> +    // FIXME: We should introduce error handling
> Is this something worth filing a bug for?


>> Source/WebCore/xml/XSLStyleSheet.h:28
>> +#include "Document.h"
> Is this #include necessary?

Removed, see below.

>> Source/WebCore/xml/XSLStyleSheet.h:73
>> +    }
> Please consider giving this function a less generic name, so that it's less likely to be misused later. Maybe createFromStringWithNullURL? Or createForXMLTreeViewer(), matching the existing createForXSLTProcessor()?

createForXMLTreeViewer() would be better. Document.h was needed as this method was taking Document* argument, not a Node* one, to decrease a chance of misuse. But since the name is clearer now, I guess Node will be fine.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list