[Webkit-unassigned] [Bug 54909] New: canAccommodateEllipsis() confuses clang's -Woverloaded-virtual
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Mon Feb 21 14:39:24 PST 2011
https://bugs.webkit.org/show_bug.cgi?id=54909
Summary: canAccommodateEllipsis() confuses clang's
-Woverloaded-virtual
Product: WebKit
Version: 528+ (Nightly build)
Platform: PC
OS/Version: Mac OS X 10.5
Status: NEW
Severity: Normal
Priority: P2
Component: WebCore Misc.
AssignedTo: webkit-unassigned at lists.webkit.org
ReportedBy: thakis at chromium.org
In file included from /b/build/slave/mac_clang/build/src/third_party/WebKit/Source/WebCore/WebCore.gyp/../dom/Node.cpp:72:
In file included from ../rendering/RenderBlock.h:30:
../rendering/RootInlineBox.h:80:10: error: 'WebCore::RootInlineBox::canAccommodateEllipsis' hides overloaded virtual function [-Woverloaded-virtual]
bool canAccommodateEllipsis(bool ltr, int blockEdge, int lineBoxEdge, int ellipsisWidth);
^
In file included from /b/build/slave/mac_clang/build/src/third_party/WebKit/Source/WebCore/WebCore.gyp/../dom/Node.cpp:72:
In file included from ../rendering/RenderBlock.h:30:
In file included from ../rendering/RootInlineBox.h:25:
../rendering/InlineFlowBox.h:178:18: note: hidden overloaded virtual function 'WebCore::InlineFlowBox::canAccommodateEllipsis' declared here
virtual bool canAccommodateEllipsis(bool ltr, int blockEdge, int ellipsisWidth);
This was added in http://trac.webkit.org/changeset/6858 and not touched since. It looks like these functions are not meant to be overrides. One of the two should be renamed.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list