[Webkit-unassigned] [Bug 54181] Implement Page Visibility API.
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Mon Feb 14 16:53:53 PST 2011
https://bugs.webkit.org/show_bug.cgi?id=54181
--- Comment #3 from Tony Gentilcore <tonyg at chromium.org> 2011-02-14 16:53:53 PST ---
The main question I have is whether this API needs to start out prefixed: webkitVisibilityState instead of visibilityState. The whatwg thread didn't seem very finalized so I bet this will go through changes.
Some questions on the API proposal:
- I think we should remove the .visible property. It is just a
convenience method that a web app can trivially determine from
visibilityState. Typically web APIs shoot for the smallest API surface
area composed of the most atomic building blocks.
- I think visibilityChange should be named visibilityStateChange. That
ties it more definitively to the visibilityState attribute, similar to
readyState and readyStateChange.
- I don't understand how visibilityState=="cache" could ever be
reached. If the page is frozen in a cache, then by definition no
JavaScript can be running to observe the property.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list