[Webkit-unassigned] [Bug 54375] [Chromium] REGRESSION(r77370): Wrong right offset for RTL popup

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Feb 13 23:48:08 PST 2011


https://bugs.webkit.org/show_bug.cgi?id=54375


Kent Tamura <tkent at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #82288|review?                     |review-
               Flag|                            |




--- Comment #3 from Kent Tamura <tkent at chromium.org>  2011-02-13 23:48:08 PST ---
(From update of attachment 82288)
View in context: https://bugs.webkit.org/attachment.cgi?id=82288&action=review

> Source/WebCore/ChangeLog:8
> +        No new tests. (OOPS!)

Please remove this line.

> Source/WebCore/ChangeLog:15
> +        (WebCore::PopupContainer::layoutAndCalculateWidgetRect): Change the input parameter to take |popupInitialCoordinate| again. And calculate correct right position with returned right offset from layoutAndRightOffset().

We don't use the || notation in WebKit.  Please remove it.

> Source/WebCore/ChangeLog:17
> +        (WebCore::PopupContainer::layoutAndRightOffset): Change the name from layout() and to return |rightOffset| value.

ditto.

> Source/WebCore/platform/chromium/PopupMenuChromium.cpp:351
> +        // Use |popupInitialCoordinate.x()| + |rightOffset| because RTL position

ditto.

> Source/WebCore/platform/chromium/PopupMenuChromium.cpp:415
> +int PopupContainer::layoutAndRightOffset()

The name layoutAndRightOffset() looks curious.  Maybe layoutAndGetRightOffset() is better?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list