[Webkit-unassigned] [Bug 48509] [GTK] Implement WebView and WebKitWebView classes for WebKit2
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Thu Feb 10 09:49:31 PST 2011
https://bugs.webkit.org/show_bug.cgi?id=48509
--- Comment #27 from Martin Robinson <mrobinson at webkit.org> 2011-02-10 09:49:31 PST ---
(From update of attachment 81961)
View in context: https://bugs.webkit.org/attachment.cgi?id=81961&action=review
> Source/WebKit2/UIProcess/gtk/WebKitWebView.cpp:41
> + gboolean disposeHasRun;
disposeRan?
> Source/WebKit2/UIProcess/gtk/WebKitWebView.cpp:50
> + guint borderWidth = gtk_container_get_border_width(GTK_CONTAINER(widget));
> + gtk_widget_get_allocation(widget, &allocation);
Does it make sense for a WebView to have a border, since it isn't a container in the traditional sense?
> Source/WebKit2/UIProcess/gtk/WebKitWebView.cpp:206
> + webView->keyPress(event);
Please have method names that use verbs. handleKeyboardEvent. keyPress is a misnomer anyway, since this is a release event.
> Source/WebKit2/UIProcess/gtk/WebKitWebView.cpp:215
> + webView->mouseActivate(reinterpret_cast<GdkEventAny*>(event));
Ditto. handleMouseEvent.
> Source/WebKit2/UIProcess/gtk/WebKitWebView.cpp:224
> + webView->mouseActivate(reinterpret_cast<GdkEventAny*>(event));
Ditto. handleMouseEvent.
> Source/WebKit2/UIProcess/gtk/WebKitWebView.cpp:232
> + webView->scroll(event);
Ditto. handleWheelEvent.
> Source/WebKit2/UIProcess/gtk/WebKitWebView.cpp:240
> + webView->mouseActivate(reinterpret_cast<GdkEventAny*>(event));
Ditto. handleMouseEvent.
> Source/WebKit2/UIProcess/gtk/WebKitWebView.h:40
> +#define WEBKIT_WEB_VIEW(obj) (G_TYPE_CHECK_INSTANCE_CAST((obj), WEBKIT_TYPE_WEB_VIEW, WebKitWebView))
Please don't abbreviate here since these are in WebKit style.
> Source/WebKit2/UIProcess/gtk/WebView.cpp:144
> + return IntRect(m_viewRect).size();
Wouldn't it make sense to just ask the widget for its allocation here?
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list