[Webkit-unassigned] [Bug 53564] Make canHaveChildrenForEditing more efficient
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Wed Feb 9 20:19:22 PST 2011
https://bugs.webkit.org/show_bug.cgi?id=53564
Eric Seidel <eric at webkit.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #81041|review? |review-
Flag| |
--- Comment #20 from Eric Seidel <eric at webkit.org> 2011-02-09 20:19:22 PST ---
(From update of attachment 81041)
View in context: https://bugs.webkit.org/attachment.cgi?id=81041&action=review
It also seems like this "can contain" concept is very similar to being a replaced element in the renderer. Are we sure they're not identical?
> Source/WebCore/dom/Document.h:440
> + bool canContainPosition() const { return true; }
Since position isn't a DOM concept (yet), I think we should rename this to talk about range end points. canContainRangeEndPoint would be fine. You had some other suggestions over IRC which sounded fine too.
> Source/WebCore/editing/htmlediting.h:87
> +inline bool canHaveChildrenForEditing(const Node* node)
Should have a FIXME about renmaing this function, since the name makes no sense to me. SEems to have nothing to do with children.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list